Author Topic: Clipon install issues.  (Read 1118 times)

0 Members and 1 Guest are viewing this topic.

  • Offline Tiral   us

    • Z900 Junior Member  ‐    8
    • *
    • Topic Author

    Offline Tiral

    • Z900 Junior Member
    • *
    • Topic Author
    • Posts: 8
    • Country: us
    • Town / City: Moline
    Clipon install issues.
    on: Apr 05, 2020, 10.44 pm
    Apr 05, 2020, 10.44 pm
    Hey all! I'm trying to install a set of "clipons" and I've hit a snag. I've gotten everything disassembled and the old bars off. The new adaptor plate is installed my only issue is the instrument cluster doesn't reach the holes to be reinstalled. I've attached a few pics to explain. Has anyone had this issue or knows what I'm doing wrong? I also have a couple left over pieces I have no idea what to do with lol. Any help is really appreciated!





  • Offline Tiral   us

    • Z900 Junior Member  ‐    8
    • *
    • Topic Author
    • #1

    Offline Tiral

    • Z900 Junior Member
    • *
    • Topic Author
    • Posts: 8
    • Country: us
    • Town / City: Moline
    Re: Clipon install issues.
    Reply #1 on: Apr 05, 2020, 11.20 pm
    Apr 05, 2020, 11.20 pm
    So apparently it installs easier when the adaptor plate isn't upside down 🤦‍♂️ Thanks everyone!

  • Offline RobZ900   gb

    • Z900 God  ‐    3174
    • *****
      #2

    Offline RobZ900

    • Z900 God
    • *****
    • Posts: 3174
    • Country: gb
    • Bike: Z900
    • Town / City: Wiltshire
    Re: Clipon install issues.
    Reply #2 on: Apr 05, 2020, 11.29 pm
    Apr 05, 2020, 11.29 pm
    Lol, answered your own question then. Pictures of the finished product?
    Motorcyclist - noun (moh-ter-sahy-klist)
    : a person willing to take a container full of flammable liquid, place it on top of a hot, moving engine and then put the whole lot between their legs!

  • Online ibnsneju   us

    • Z900 Member  ‐    23
    • **
      #3

    Online ibnsneju

    • Z900 Member
    • **
    • Posts: 23
    • Country: us
    • Town / City: Altanta
    Re: Clipon install issues.
    Reply #3 on: Sep 23, 2022, 01.50 am
    Sep 23, 2022, 01.50 am
    Are these the ones from alibaba?

  • Offline az90022   us

    • Z900 Junior Member  ‐    1
    • *
      #4

    Offline az90022

    • Z900 Junior Member
    • *
    • Posts: 1
    • Country: us
    • Town / City: Tucson
    Re: Clipon install issues.
    Reply #4 on: Sep 26, 2022, 04.40 pm
    Sep 26, 2022, 04.40 pm
    Please review this when you have time.  Also would love some pictures of the final installation.  Thx.