Z900

Please login or register.

News: A big welcome to all new members !



Author [ES] [MY] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [NO] [GR] [TR] Topic: Z900 ABS , version 2020, CEL light blinking , error code not displaying,  (Read 2177 times)

0 Members and 1 Guest are viewing this topic.

Offline Indian_girl

  • Z900 Junior Member
  • *
  • Topic Author (OP)
  • Posts: 4
  • Country: in
i have new z900 ABS , 2020 version which have full digital display.  now i came to know that orange check engine light is blinking. as i came to know its not always engine problem but various other faults in bikes can cause this, for that i need to see error code.  i searched in every forum googling different sites, but all answers are of older model of z900. even their are same question like me but bike model is of older version.  i have tried the most common procedure in odometer mode by pressing both the button on left hand side and right hand side, but the only think the comes is the option of "display","bluetooth","clocksettings". etc . i entered each option but couldn't find any error code option. and the error code is not displaying . my service center is around 300km from my home, so i just wanted to know the error code , if its a minor problem or major problem which i should be stop driving . 

Offline BlueRibbonRM

  • Z900 Pro
  • ***
  • Posts: 215
  • Bike: 2020 Z900
  • Town / City: Collegeville
  • Country: us
On my 2020 when the engine light came on I did the press both buttons and it displayed the code for me. After my ecu flash I learned the hard way that it does not bypass the EVAP purge valve code and now until the light finally clears out I cannot access the menu for clock, bluetooth etc.  as it just displays the trouble code.

Offline Indian_girl

  • Z900 Junior Member
  • *
  • Topic Author (OP)
  • Posts: 4
  • Country: in
Hi bro, do you have any solution? , its still blinking and when i press both button , it just give option, like bluetooh,display,units,clock etc options . if you have any solution can you explain in details?

Offline BlueRibbonRM

  • Z900 Pro
  • ***
  • Posts: 215
  • Bike: 2020 Z900
  • Town / City: Collegeville
  • Country: us
All I know is that my bike currently will not let me enter the option screen as it just displays the code instead.  However my engine light isn't blinking just stays on solid so maybe the blinking is indicating something else. With a car a flashing light means severe misfire, I assume you have no other running issues though? I just paged through the owner's manual and nowhere does it mention the meaning of the engine light blinking, only on solid. A few other lights on the gauge have mention of the possibility of blinking though.

Offline Led Zed 70

  • Z900 Master
  • ****
  • Posts: 732
  • Bike: 2017 Z900ABS
  • Town / City: Round Rock
  • Country: us
Probably wont work but it wont hurt either, try disconnecting neg lead on battery for a few minutes then reattach.

Offline Indian_girl

  • Z900 Junior Member
  • *
  • Topic Author (OP)
  • Posts: 4
  • Country: in
today i disconnected the battery for 5 mins and reattached but still didn't work, so today i read the manual ,but their was nothing specific, only stated that orange engine  light may be sign of fuel injection problem.  nothing in the manual book specific for error checking code. so only option for me is to drive 200 miles for service center, and god knows what could happen during the ride.

Offline Cazzy_R

  • Z900 God
  • *****
  • Posts: 2567
  • Bike: 2017 z900
  • Town / City: Merseyside/W Lancs.
  • Country: england
*Originally Posted by Indian_girl [+]
today i disconnected the battery for 5 mins and reattached but still didn't work, so today i read the manual ,but their was nothing specific, only stated that orange engine  light may be sign of fuel injection problem.  nothing in the manual book specific for error checking code. so only option for me is to drive 200 miles for service center, and god knows what could happen during the ride.

Is it still under warranty?
In the UK we get recovery cover as part of the warranty. Does that apply in India?
If your dealer deems it unsafe to ride without potentially incurring additional engine damage they should recover it.
If on the other hand they say it's fine to ride then make sure you have proof of them saying that in writing (text. whatsapp, email) or voice recording.
Then if it goes t*ts up on the journey there its on them.
Tighten it 'til it strips then back it off half a turn.

Offline Khukinatya

  • Z900 Junior Member
  • *
  • Posts: 3
  • Bike: 2021/Z900
  • Town / City: Budapest
  • Country: hu
I feel for you. I am in the same boat...
Bought a brand new 2021 model in december and at the handover the CEL was already blinking. It's like blink-blink-pause, blink-blink-pause. I've asked the dealer about it and he said "this bike is smarter than us, it will turn off when you start riding". I was naive, I've trusted him.  :012:
We carried it home 160 kms.
After I rode it a little, CEL was still blinking. The dealer told me I should disconnect the battery but it didn't worked. Then he wrote me that it's probably caused by low battery voltage :187: and I can ride it if the CEL is not constantly on, but my first ride should lead to their workshop...
I've even tried to read the fault code myself with a ELM327 (+kawasaki adapter cable) but no luck connecting to ECU.  :003:

Offline Led Zed 70

  • Z900 Master
  • ****
  • Posts: 732
  • Bike: 2017 Z900ABS
  • Town / City: Round Rock
  • Country: us
Can yall maybe reach out to the closest Kawasaki headquarters since dealers arent any help? Seams like a very important issue that needs to be addressed ASAP.

Offline Indian_girl

  • Z900 Junior Member
  • *
  • Topic Author (OP)
  • Posts: 4
  • Country: in
yeah may be result of installing too much electronic in new version or may be genuine problem. the only fear is that if untrained dealer mechanics will say "just drive no problem, its a fault blink". and you will never know what is the problem.