Z900

Please login or register.

News: A big welcome to all new members !



Author [ES] [MY] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [NO] [GR] [TR] Topic: ABS fault, stuck in rain mode  (Read 626 times)

0 Members and 1 Guest are viewing this topic.

Offline adamn58

  • Z900 Member
  • **
  • Topic Author (OP)
  • Posts: 27
  • Bike: 2020 Z900
  • Country: us
ABS fault, stuck in rain mode
on: June 08, 2021, 04:48:09 PM
As I mentioned in a previous discussion, I had a small fire that melted most of my plastics.  Since then I have started replacing plastics but I noticed the ABS and Power lights flashing on my dash.  I checked all the ABS systems and rings and they visually look perfect.  Also my ABS appears to work, however my bike seems to be locked in rain mode but my display says I am in road mode.  Has anyone ever experienced this before?  My mechanic and I seem to believe that a code tripped the lights and that because the ECU can't reset codes automatically it likely just needs to be cleared.  Any insight on this would be appreciated.  (just as a side note, this bike is a beast.  Took the fire like a champ!)

Offline porkchop

  • Z900 Master
  • ****
  • Posts: 554
  • Bike: 2019
  • Town / City: Central NY
  • Country: us
Re: ABS fault, stuck in rain mode
Reply #1 on: June 08, 2021, 05:38:59 PM
What code is coming up?
Take it to a dealer and have them try to clear it, you may have bigger problems- like with the wiring or a sensor? 
"The ride is the reason"

Offline adamn58

  • Z900 Member
  • **
  • Topic Author (OP)
  • Posts: 27
  • Bike: 2020 Z900
  • Country: us
Re: ABS fault, stuck in rain mode
Reply #2 on: June 08, 2021, 05:58:33 PM
*Originally Posted by porkchop [+]
What code is coming up?
Take it to a dealer and have them try to clear it, you may have bigger problems- like with the wiring or a sensor?
I was unable to get a code to appear but I'm new to using the weird dash.  I actually work at the dealership but the service dept is pretty backlogged with riding season kicking into gear.  I was just wondering if anyone had had something similar with the low power mode being locked on so I could get some parts on the way as quick as possible.

Offline adamn58

  • Z900 Member
  • **
  • Topic Author (OP)
  • Posts: 27
  • Bike: 2020 Z900
  • Country: us
Re: ABS fault, stuck in rain mode
Reply #3 on: June 08, 2021, 11:15:14 PM
Turns out no parts were needed.  Rear wheel speed sensor fault tripped at some point and put it in a limp mode.  Had them reset the code and rode for a couple hours with no issues.