Z900

Please login or register.

News: A big welcome to all new members !



Author [ES] [MY] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [NO] [GR] [TR] Topic: 2019 Z900 fail to crank (but just once)  (Read 490 times)

0 Members and 1 Guest are viewing this topic.

Offline dogbreath

  • Z900 Member
  • **
  • Topic Author (OP)
  • Posts: 18
  • Bike: Z900, Katana 11
  • Town / City: Hell, MI
  • Country: us
2019 Z900 fail to crank (but just once)
on: July 26, 2021, 06:22:06 AM

Hot day, 90F. Stopped because the right mirror came loose and I wanted to see if it was gonna fall off. Bike idled for about 2 minutes. Went to get back on and didn't put the kickstand all the way up (ope) and it shut off. Got a jump start about 15 minutes later but I'm not convinced it actually needed it. Hasn't had a problem since, cranks like it has a brand new battery.

I'm thinking the starter got heat soaked. Anyone care to ruminate with me?

Offline Frontline

  • Forum Supporter
  • Z900 God
  • *
  • Posts: 1806
  • Bike: 2018 Z900 ABS
  • Town / City: Florida
  • Country: us
Re: 2019 Z900 fail to crank (but just once)
Reply #1 on: July 26, 2021, 01:17:37 PM
2 minutes at 90F air is nothing and you only had 4 bars lit on temp gauge! That's a normal "cool" summer day here. If mine doesn't suffer any heat related issues, nobody else on this forum (or planet) will either  :150:

It's likely a battery connection or the battery itself. My original battery lasted only 20 months. While its possible you have a fussy starter relay, its time (IMO) to change battery as that is a consumable that will need change anyways.
SAVE OUR RACECARS! - Support the RPM Act - SEMA.ORG/RPM

Offline Its about speed

  • Z900 Member
  • **
  • Posts: 89
  • Bike: 2017 Z900 ABS
  • Town / City: REDDING, CA
  • Country: us
Re: 2019 Z900 fail to crank (but just once)
Reply #2 on: July 26, 2021, 04:56:56 PM
Before buying new parts, do some troubleshooting.

The safety switches are problematic. The side stand is suspected on your bike. Commit a couple hours at home to remove and replace the entire sidestand system. All of it. Use a rear jack.

A lot of debris collects on the bike's lower construction. WD-40 works as a cleaner and offers pretty good lube. It also benefits electrical components.

You shouldn't idle a hot bike for 2 minutes. The naked look is actually a preferred exhaust cooling system.

Offline mininsx

  • Z900 Pro
  • ***
  • Posts: 218
  • Bike: '17 Z900, '19 SV650
  • Town / City: Central Kentucky
  • Country: us
Re: 2019 Z900 fail to crank (but just once)
Reply #3 on: July 26, 2021, 10:12:50 PM
Hook up a volt/ohm meter and crank it over. If it drops below 9 volts your battery is bad. While you're at it check the charging system.

Offline dogbreath

  • Z900 Member
  • **
  • Topic Author (OP)
  • Posts: 18
  • Bike: Z900, Katana 11
  • Town / City: Hell, MI
  • Country: us
Re: 2019 Z900 fail to crank (but just once)
Reply #4 on: July 26, 2021, 11:33:21 PM
*Originally Posted by mininsx [+]
Hook up a volt/ohm meter and crank it over. If it drops below 9 volts your battery is bad. While you're at it check the charging system.

I tested the battery and charging and everything checked out, but I haven't recreated the scenario exactly. I've been keeping the DVOM in the saddlebags so if it happens again I can test right away.