Author Help please! Oil in exhaust ports?  (Read 458 times)

0 Members and 1 Guest are viewing this topic.

  • Offline Delvryboy   us

    • Z900 Member  ‐    62
    • **
    • Topic Author

    Offline Delvryboy

    • Z900 Member
    • **
    • Topic Author
    • Posts: 62
    • Country: us
    Help please! Oil in exhaust ports?
    on: Mar 12, 2023, 12.27 am
    Mar 12, 2023, 12.27 am
    *** Please move to Maintenance and Servicing if needed

    Hi all,

    Bike is a 2022 and has 3k on it.

    I took down the exhaust to finish gutting the cat, and I have a small amount of oil (not so really fresh) in each exhaust port. I donít recall seeing this when I had the header off last, around 1500 miles, and my oil level hasnít moved that I can tell, and no external leaking. Also, itís never burnt any oil that Iíve seen or smelled. Inside of the header is clean.

    Iím at a point that I can put it back to stock and give it to the dealer for the season. But, I need help soon, the ECU is packaged up on my desk ready to ship out. lol

    The paper towel is pretty much all of the oil from the 4 ports.













    PS - can anybody identify this spring? I swear, I found it on the floor under the bike, but I didnít touch anything that has a spring like this. I thought, maybe it was the spring from the oem break lever, but itís still there in my toolbox. Itís driving me crazy, I went over the entire OEM parts diagram - every damn bolt. I just want to rule it out.








    Last Edit: Mar 12, 2023, 12.40 am by Delvryboy

  • Offline 3alfa3   hr

    • Z900 Master  ‐    710
    • ****
      #1

    Offline 3alfa3

    • Z900 Master
    • ****
    • Posts: 710
    • Bike: 2020 Z900
    • Town / City: Zagreb
    • Country: hr
    Re: Help please! Oil in exhaust ports?
    Reply #1 on: Mar 12, 2023, 12.47 am
    Mar 12, 2023, 12.47 am
    Spring....   Did you remove OEM Clutch lever (one Spring is inside)?

  • Offline Delvryboy   us

    • Z900 Member  ‐    62
    • **
    • Topic Author
    • #2

    Offline Delvryboy

    • Z900 Member
    • **
    • Topic Author
    • Posts: 62
    • Country: us
    Re: Help please! Oil in exhaust ports?
    Reply #2 on: Mar 12, 2023, 01.03 am
    Mar 12, 2023, 01.03 am
    *Originally Posted by 3alfa3 [+]
    Spring....   Did you remove OEM Clutch lever (one Spring is inside)?
    I did!  Iíll check it, I just moved them from a cabinet to a box on my tool cart yesterday, it could have easily fallen. Thanks!

  • Offline Moto.Maddox   us

    • Z900 Member  ‐    57
    • **
      #3

    Offline Moto.Maddox

    • Z900 Member
    • **
    • Posts: 57
    • Bike: 2022 Kawasaki z900
    • Country: us
    Re: Help please! Oil in exhaust ports?
    Reply #3 on: Mar 12, 2023, 05.20 pm
    Mar 12, 2023, 05.20 pm
    Keep us updated on the mystery spring.  It's like when you have to fully assemble something and then have some "left over/extra" parts...very unsettling.

  • Offline Delvryboy   us

    • Z900 Member  ‐    62
    • **
    • Topic Author
    • #4

    Offline Delvryboy

    • Z900 Member
    • **
    • Topic Author
    • Posts: 62
    • Country: us
    Re: Help please! Oil in exhaust ports?
    Reply #4 on: Mar 12, 2023, 07.12 pm
    Mar 12, 2023, 07.12 pm
    Confirmed on the clutch lever spring.  I had the lever zip tied with the spring in place and it all came undone when I was moving it.  I just happened to find it under the bike a week later.


     



    rockbound